Usuários PHP alertam ​​para não atualizar para v5.3.7

Os desenvolvedores PHP alertaram os usuários para não atualizar o PHP para a versão estável mais recente da linguagem de script PHP devido a um bug sério. No PHP 5.3.7, na atualização de segurança e manutenção realizada semana passada a função crypt () que é usada para cifrar uma string – tipicamente uma senha – falha se um salto MD5 é dado como argumento. Nesse caso, ao invés de retornar a string cifrada, a função apenas retorna a string em si.
Em nota os desenvolvedores disseram que :”DES e BLOWFISH funcionaram como esperado”. Até que uma atualização que corrija o bug seja disponibilizada, os desenvolvedores não aconselham usuários à atualizar para v5.3.7, a versão 5.3.8 é esperada para chegar nos próximo dias.

Fonte The H-Open – Noticia Original

Artigos Relacionados:

Deixe uma resposta

O seu endereço de email não será publicado Campos obrigatórios são marcados *